Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

rPSA-2007-0117-1 gd php php-mysql php-pgsql
From: rPath Update Announcements <announce-noreply () rpath com>
Date: Thu, 07 Jun 2007 18:27:24 -0400

rPath Security Advisory: 2007-0117-1
Published: 2007-06-07
Products: rPath Linux 1
Rating: Minor
Exposure Level Classification:
    Indirect User Deterministic Denial of Service
Updated Versions:
    gd=/conary.rpath.com () rpl:devel//1/2.0.33-4.4-1
    php=/conary.rpath.com () rpl:devel//1/4.3.11-15.11-1
    php-mysql=/conary.rpath.com () rpl:devel//1/4.3.11-15.11-1
    php-pgsql=/conary.rpath.com () rpl:devel//1/4.3.11-15.11-1

References:
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2756
    https://issues.rpath.com/browse/RPL-1394

Description:
    Previous versions of the gd and php packages are vulnerable to a Denial
    of Service attack in which an attacker can use a truncated PNG image to
    cause unbounded CPU consumption.  The libgd library is not exposed via
    any privileged or remote interfaces within rPath Linux per se, but it is
    exposed by some web applications, such as php (which provides its own
    internal version of libgd).

Copyright 2007 rPath, Inc.
This file is distributed under the terms of the MIT License.
A copy is available at http://www.rpath.com/permanent/mit-license.html

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • rPSA-2007-0117-1 gd php php-mysql php-pgsql rPath Update Announcements (Jun 08)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]