Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[ GLSA 200703-15 ] PostgreSQL: Multiple vulnerabilities
From: Raphael Marichez <falco () gentoo org>
Date: Fri, 16 Mar 2007 23:39:25 +0100

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200703-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PostgreSQL: Multiple vulnerabilities
      Date: March 16, 2007
      Bugs: #165482
        ID: 200703-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PostgreSQL contains two vulnerabilities that could result in a Denial
of Service or unauthorized access to certain information.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql      < 8.0.11                         >= 8.0.11
                                                            *>= 7.4.16
                                                            *>= 7.3.13

Description
===========

PostgreSQL does not correctly check the data types of the SQL function
arguments under unspecified circumstances nor the format of the
provided tables in the query planner.

Impact
======

A remote authenticated attacker could send specially crafted queries to
the server that could result in a server crash and possibly the
unauthorized reading of some database content or arbitrary memory.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose "dev-db/postgresql"

References
==========

  [ 1 ] CVE-2007-0555
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0555
  [ 2 ] CVE-2007-0556
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0556

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200703-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

  By Date           By Thread  

Current thread:
  • [ GLSA 200703-15 ] PostgreSQL: Multiple vulnerabilities Raphael Marichez (Mar 17)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]