Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[ GLSA 200705-19 ] PHP: Multiple vulnerabilities
From: Raphael Marichez <falco () gentoo org>
Date: Sat, 26 May 2007 21:23:16 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200705-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PHP: Multiple vulnerabilities
      Date: May 26, 2007
      Bugs: #169372
        ID: 200705-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PHP contains several vulnerabilities including buffer and integer
overflows which could under certain conditions lead to the remote
execution of arbitrary code.

Background
==========

PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php       < 5.2.2                              *>= 4.4.7
                                                              >= 5.2.2

Description
===========

Several vulnerabilities were found in PHP, most of them during the
Month Of PHP Bugs (MOPB) by Stefan Esser. The most severe of these
vulnerabilities are integer overflows in wbmp.c from the GD library
(CVE-2007-1001) and in the substr_compare() PHP 5 function
(CVE-2007-1375). Ilia Alshanetsky also reported a buffer overflow in
the make_http_soap_request() and in the user_filter_factory_create()
functions (CVE-2007-2510, CVE-2007-2511), and Stanislav Malyshev
discovered another buffer overflow in the bundled XMLRPC library
(CVE-2007-1864). Additionally, the session_regenerate_id() and the
array_user_key_compare() functions contain a double-free vulnerability
(CVE-2007-1484, CVE-2007-1521). Finally, there exist implementation
errors in the Zend engine, in the mb_parse_str(), the unserialize() and
the mail() functions and other elements.

Impact
======

Remote attackers might be able to exploit these issues in PHP
applications making use of the affected functions, potentially
resulting in the execution of arbitrary code, Denial of Service,
execution of scripted contents in the context of the affected site,
security bypass or information leak.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 5 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/php-5.2.2"

All PHP 4 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.7"

References
==========

  [ 1 ] CVE-2007-1001
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1001
  [ 2 ] CVE-2007-1285
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1285
  [ 3 ] CVE-2007-1286
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1286
  [ 4 ] CVE-2007-1484
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1484
  [ 5 ] CVE-2007-1521
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1521
  [ 6 ] CVE-2007-1583
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1583
  [ 7 ] CVE-2007-1700
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1700
  [ 8 ] CVE-2007-1701
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1701
  [ 9 ] CVE-2007-1711
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1711
  [ 10 ] CVE-2007-1717
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1717
  [ 11 ] CVE-2007-1718
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1718
  [ 12 ] CVE-2007-1864
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1864
  [ 13 ] CVE-2007-1900
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1900
  [ 14 ] CVE-2007-2509
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2509
  [ 15 ] CVE-2007-2510
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2510
  [ 16 ] CVE-2007-2511
         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2511

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200705-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

  By Date           By Thread  

Current thread:
  • [ GLSA 200705-19 ] PHP: Multiple vulnerabilities Raphael Marichez (May 26)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]