Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Re: CAT6500 accessible via 127.0.0.x loopback addresses
From: Ilker Temir <itemir () cisco com>
Date: Thu, 27 Sep 2007 00:22:00 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Cisco Security Response: Catalyst 6500 and Cisco 7600 Series Devices
Accessible via Loopback Address

http://www.cisco.com/warp/public/707/cisco-sr-20070926-lb.shtml

Revision 1.0

For Public Release 2007 September 26 2200 UTC (GMT)

Cisco Response
==============

This document is the Cisco PSIRT response to an issue regarding Cisco
Catalyst 6500 and Cisco 7600 series devices that was discovered and
reported to Cisco by Lee E. Rian.

The original report has been posted to full-disclosure mailing list.

Cisco PSIRT greatly appreciates the opportunity to work with
researchers on security vulnerabilities, and we welcome the
opportunity to review and assist in product reports.

This vulnerability is documented in Cisco bug ID CSCsg02323.

This Cisco Security Response is available at the following link:
http://www.cisco.com/warp/public/707/cisco-sr-20070926-lb.shtml

Additional Information
======================

Cisco Catalyst 6500 and Cisco 7600 series devices use addresses from
the 127.0.0.0/8 (loopback) range in the Ethernet Out-of-Band Channel
(EOBC) for internal communication.

Addresses from this range that are used in the EOBC on Cisco Catalyst
6500 and Cisco 7600 series devices are accessible from outside of the
system. The Supervisor module, Multilayer Switch Feature Card (MSFC),
or any other intelligent module may receive and process packets that
are destined for the 127.0.0.0/8 network. An attacker can exploit
this behavior to bypass existing access control lists that do not
filter 127.0.0.0/8 address range; however, an exploit will not allow
an attacker to bypass authentication or authorization. Valid
authentication credentials are still required to access the module in
question.

Per RFC 3330, a packet that is sent to an address anywhere within the
127.0.0.0/8 address range should loop back inside the host and should
never reach the physical network. However, some host implementations
send packets to addresses in the 127.0.0.0/8 range outside their
Network Interface Card (NIC) and to the network. Certain
implementations that normally do not send packets to addresses in the
127.0.0.0/8 range may also be configured to do so.

Destination addresses in the 127.0.0.0/8 range are not routed on the
Internet. This factor limits the exposure of this issue.

This issue is applicable to systems that run Hybrid Mode (Catalyst OS
(CatOS) software on the Supervisor Engine and IOS Software on the
MSFC) and Native Mode (IOS Software on both the Supervisor Engine and
the MSFC).

This issue has been documented by the Cisco bug ID CSCsg02323 (
registered customers only) . All software versions that run on Cisco
Catalyst 6500 and Cisco 7600 series devices are affected. A fix is
available in 12.2(33)SXH.

As a workaround, administrators can apply an access control list that
filters packets to the 127.0.0.0/8 address range to interfaces where
attacks may be launched.

    ip access-list extended block_loopback
      deny   ip any 127.0.0.0 0.255.255.255
      permit ip any any

    interface Vlan x
     ip access-group block_loopback in


Control Plane Policing (CoPP) can be used to block traffic with a
destination IP address in the 127.0.0.0/8 address range sent to the
device. Cisco IOS Software releases 12.0S, 12.2SX, 12.2S, 12.3T,
12.4, and 12.4T support the CoPP feature. CoPP may be configured on a
device to protect the management and control planes to minimize the
risk and effectiveness of direct infrastructure attacks. CoPP
protects the management and control planes by explicitly permitting
only authorized traffic that is sent to infrastructure devices in
accordance with existing security policies and configurations.


    !-- Permit all traffic with a destination IP
    !-- addresses in the 127.0.0.0/8 address range sent to
    !-- the affected device so that it will be policed and
    !-- dropped by the CoPP feature
    !

    access-list 111 permit icmp any 127.0.0.0 0.255.255.255
    access-list 111 permit udp any 127.0.0.0 0.255.255.255
    access-list 111 permit tcp any 127.0.0.0 0.255.255.255
    access-list 111 permit ip any 127.0.0.0 0.255.255.255

    !
    !-- Permit (Police or Drop)/Deny (Allow) all other Layer3
    !-- and Layer4 traffic in accordance with existing security
    !-- policies and configurations for traffic that is authorized
    !-- to be sent to infrastructure devices
    !
    !-- Create a Class-Map for traffic to be policed by the
    !-- CoPP feature
    !

    class-map match-all drop-127/8-netblock-class
      match access-group 111

    !
    !-- Create a Policy-Map that will be applied to the
    !-- Control-Plane of the device.
    !

    policy-map drop-127/8-netblock-traffic
      class drop-127/8-netblock-class
        police 32000 1500 1500 conform-action drop exceed-action drop

    !
    !-- Apply the Policy-Map to the Control-Plane of the
    !-- device
    !

    control-plane
      service-policy input drop-127/8-netblock-traffic

    !



Additional information on the configuration and use of the CoPP
feature is available at the following links:

http://www.cisco.com/en/US/products/ps6642/products_white_paper0900aecd804fa16a.shtml

http://www.cisco.com/en/US/products/sw/iosswrel/ps1838/products_feature_guide09186a008052446b.html

Infrastructure Access Control Lists (iACLs) are also considered a
network security best practice and should be considered as, long-term
additions to effective network security as well as a workaround for
this specific issue. The white paper entitled "Protecting Your Core:
Infrastructure Protection Access Control Lists" presents guidelines
and recommended deployment techniques for infrastructure protection
ACLs. The white paper is available at the following link:

http://www.cisco.com/warp/public/707/iacl.html

Additional mitigations that can be deployed on Cisco devices within
the network are available in the Cisco Applied Intelligence companion
document for this response:

http://www.cisco.com/warp/public/707/cisco-air-20070926-lb.shtml

Additional Information
======================

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY
KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE
INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS
AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS
DOCUMENT AT ANY TIME.

Revision History
================

+-----------------------------------------+
| Revision |                   | Initial  |
| 1.0      | 2007-September-26 | public   |
|          |                   | release. |
+-----------------------------------------+

Cisco Security Procedures
=========================

Complete information on reporting security vulnerabilities in Cisco
products, obtaining assistance with security incidents, and
registering to receive security information from Cisco, is available
on Cisco's worldwide website at
http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html.

This includes instructions for press inquiries regarding Cisco security
notices.  All Cisco security advisories are available at
http://www.cisco.com/go/psirt.

lee.e.rian () census gov wrote:
Lee E Rian/TCO/HQ/BOC wrote on 08/29/2006 01:49:40 PM:
I found something interesting w/ the cat6000s - telnet 127.0.0.11
gets you into the switch & telnet 127.0.0.12 gets you into the router

% snmpget 127.0.0.11 sysDescr.0
RFC1213-MIB::sysDescr.0 = STRING: "Cisco Systems WS-C6509.Cisco
Catalyst Operating System Software, Version 5.5(18).Copyright (c)
1995-2002 by Cisco Systems."

    <.. snip ..>

I'm trying to figure out if that opens us up to something or not.


Yes, the date is correct - it was a bit over a year ago when I wrote a
co-worker about the problem.  And it did open us up to an attacker gaining
access to the router or switch; I sent a msg to Cisco PSIRT the same day.

Cisco has documented the fix in the release notes
  (eg.
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/ol_4164.htm#wp3511819)
but it's buried in the release notes and how many people will a) read the
release notes and b) realize the implications?  So while I agree with Cisco
about this being a low to moderate vulnerability, that's only if one
realizes that the various line cards in a catalyst 6500 are accessible via
127.0.0.xx addresses from the network.  At least in my mind, this is on the
same level as routers accepting snmp sets to 255.255.255.255, {network, 0}
and {network, -1} ... a minor issue as long as you realize that it is
possible to access the router/switch that way.

Mitigating factors:
- an attacker would still need to know/guess the snmp community string or
userid/password
- only the first cat6000 with an MSFC in the path can be accessed this way

As an example of 'only the first MSFC in the path', the path from one of
our remote offices to a data center is
 cat6500 with a supervisor 2 card (no MSFC)
 cisco 2800 router
 cisco 7200 router
 cat6500 with a SUP720 in slot 5
Anyone in that remote office would have been able to access the data center
cat6500 by sending traffic to 127.0.0.51.



I would like to thank Ilker Temir of Cisco for his professionalism and many
courtesies extended to me while working on this issue.

Lee Rian


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFG+tuI8/wE0ppYtwURAvgxAKC+rz2Ov1OB0pwAjbTyYE18Zpu6KQCffJfB
v0N1xPDSyPGCEcleYjGrXp0=
=7dQL
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault