Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

rPSA-2008-0241-1 openssl openssl-scripts
From: rPath Update Announcements <announce-noreply () rpath com>
Date: Wed, 30 Jul 2008 19:27:27 -0400

rPath Security Advisory: 2008-0241-1
Published: 2008-07-30
Products:
    rPath Linux 1

Rating: Major
Exposure Level Classification:
    Remote Deterministic Unauthorized Access
Updated Versions:
    openssl=conary.rpath.com () rpl:1-compat/0.9.7a-0.5-2
    openssl-scripts=conary.rpath.com () rpl:1-compat/0.9.7a-0.5-2

rPath Issue Tracking System:
    https://issues.rpath.com/browse/RPL-1770

References:
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5135

Description:
    Previous versions of the legacy openssl compatibility package are
    vulnerable to a buffer overflow, possibly enabling remote attackers 
    to execute arbitrary code through applications that use the openssl
    libraries.
    
    This compatibility library was provided solely for transient
    compatibility with applications built for alpha releases of rPath
    Linux, to make it easier for alpha testers to upgrade their systems
    to rPath Linux 1.  rPath is not aware of any applications that
    currently use these libraries, and so it is unlikely that any
    systems will actually be vulnerable to these attacks.

http://wiki.rpath.com/Advisories:rPSA-2008-0241

Copyright 2008 rPath, Inc.
This file is distributed under the terms of the MIT License.
A copy is available at http://www.rpath.com/permanent/mit-license.html

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • rPSA-2008-0241-1 openssl openssl-scripts rPath Update Announcements (Jul 31)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault