Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[ GLSA 200809-01 ] yelp: User-assisted execution of arbitrary code
From: Robert Buchholz <rbu () gentoo org>
Date: Thu, 4 Sep 2008 21:09:04 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200809-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: yelp: User-assisted execution of arbitrary code
      Date: September 04, 2008
      Bugs: #234079
        ID: 200809-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in yelp can lead to the execution of arbitrary code
when opening a URI, for example through Firefox.

Background
==========

yelp is the default help browser for GNOME.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
  1  gnome-extra/yelp      < 2.22.1-r2                    >= 2.22.1-r2
                                                         *>= 2.20.0-r1

Description
===========

Aaron Grattafiori reported a format string vulnerability in the
window_error() function in yelp-window.c.

Impact
======

A remote attacker can entice a user to open specially crafted "man:" or
"ghelp:" URIs in yelp, or an application using yelp such as Firefox or
Evolution, and execute arbitrary code with the privileges of that user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All yelp users running GNOME 2.22 should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=gnome-extra/yelp-2.22.1-r2"

All yelp users running GNOME 2.20 should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=gnome-extra/yelp-2.20.0-r1"

References
==========

  [ 1 ] CVE-2008-3533
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3533

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200809-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

  By Date           By Thread  

Current thread:
  • [ GLSA 200809-01 ] yelp: User-assisted execution of arbitrary code Robert Buchholz (Sep 04)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]