Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Vulnerability in sfWpCumulusPlugin for symfony
From: "MustLive" <mustlive () websecurity com ua>
Date: Tue, 15 Mar 2011 16:54:19 +0200

Hello list!

I want to warn you about Cross-Site Scripting vulnerability in plugin 
sfWpCumulusPlugin for symfony.

-------------------------
Affected products:
-------------------------

Vulnerable are all versions of sfWpCumulusPlugin.

----------
Details:
----------

This XSS is similar to XSS vulnerability in WP-Cumulus, because it's using
tagcloud.swf made by author of WP-Cumulus. About such vulnerabilities I
wrote in 2009-2011, particularly about millions of flash files tagcloud.swf
which are vulnerable to XSS attacks I mentioned in my article XSS
vulnerabilities in 34 millions flash files
(http://lists.webappsec.org/pipermail/websecurity_lists.webappsec.org/2010-January/006033.html).

XSS (WASC-08):

http://site/sfWpCumulusPlugin/swf/wp-cumulus.swf?mode=tags&tagcloud=%3Ctags%3E%3Ca+href='javascript:alert(document.cookie)'+style='font-size:+40pt'%3EClick%20me%3C/a%3E%3C/tags%3E

Code will execute after click. It's strictly social XSS. Also it's possible
to conduct (like in WP-Cumulus) HTML Injection attack.

------------
Timeline:
------------

2011.03.14 - disclosed at my site.
2011.03.15 - informed developers of symfony and of the plugin.

I mentioned about this vulnerability at my site
(http://websecurity.com.ua/5002/).

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua 


_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • Vulnerability in sfWpCumulusPlugin for symfony MustLive (Mar 15)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]