Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Vulnerabilities in MaxSite Anti Spam Image for WordPress
From: "MustLive" <mustlive () websecurity com ua>
Date: Thu, 31 Mar 2011 15:22:48 +0300

Hello list!

I want to warn you about Insufficient Anti-automation vulnerability in
MaxSite Anti Spam Image plugin for WordPress.

This is modified version of original plugin Anti Spam Image, about
vulnerability in which I wrote in 2007 in my project Month of Bugs in
Captchas. This captcha is vulnerable to session reusing with constant
captcha bypass method, like original Anti Spam Image, on which base this
plugin is made.

-------------------------
Affected products:
-------------------------

Vulnerable are MaxSite Anti Spam Image 0.6 and potentially all other
versions of this plugin.

----------
Details:
----------

Insufficient Anti-automation (WASC-21):

Exploit:

http://websecurity.com.ua/uploads/2011/MaxSite%20Anti%20Spam%20Image%20CAPTCHA%20bypass.html

Vulnerability has place on old versions of PHP. It shows only in PHP <
4.4.7, which has bug which leads to error in work of web application's
algorithm, which leads to possibility of captcha bypass.

------------
Timeline:
------------

2007.12.01 - found vulnerability.
2007.12.01 - informed developer.
2011.03.29 - disclosed at my site.

I mentioned about this vulnerability at my site
(http://websecurity.com.ua/5045/).

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua


_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • Vulnerabilities in MaxSite Anti Spam Image for WordPress MustLive (Mar 31)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault