Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[Security-news] SA-CONTRIB-2012-071 - Glossify - Cross Site Scripting (XSS) - Unsupported
From: security-news () drupal org
Date: Wed, 2 May 2012 19:15:56 +0000 (UTC)

View online: http://drupal.org/node/1557874

  * Advisory ID: DRUPAL-SA-CONTRIB-2012-071
  * Project: Glossify Internal Links Auto SEO [1] (third-party module)
  * Version: 6.x
  * Date: 2012-May-02
  * Security risk: Moderately critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

This module generates internal node to node, node to taxonomy or node to
external URL links (crosslinks) automatically - ideal for SEO of your site's
pages and partner pages.
This module does not protect against an Cross Site Scripting (XSS) attack.
The vulnerability is mitigated by the fact that the attacker must be able to
create or edit any of: content (nodes), vocabularies, or terms.

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * 6.x-2.5 and before

Drupal core is not affected. If you do not use the contributed Glossify
Internal Links Auto SEO [3] module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Uninstall the module, it is no longer supported.

Also see the Glossify Internal Links Auto SEO [4] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * Andrei Turcanu

-------- COORDINATED BY  
------------------------------------------------------

  * Michael Hess [5] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [6].

Learn more about the Drupal Security team and their policies [7], writing
secure code for Drupal [8], and securing your site [9].


[1] http://drupal.org/project/glossify
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/glossify
[4] http://drupal.org/project/glossify
[5] http://drupal.org/user/102818
[6] http://drupal.org/contact
[7] http://drupal.org/security-team
[8] http://drupal.org/writing-secure-code
[9] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news () drupal org
http://lists.drupal.org/mailman/listinfo/security-news

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • [Security-news] SA-CONTRIB-2012-071 - Glossify - Cross Site Scripting (XSS) - Unsupported security-news (May 02)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault