Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[Security-news] SA-CONTRIB-2012-084 - Search API - Cross Site Scripting (XSS)
From: security-news () drupal org
Date: Wed, 23 May 2012 20:24:33 +0000 (UTC)

View online: http://drupal.org/node/1597364

  * Advisory ID: DRUPAL-SA-CONTRIB-2012-084
  * Project: Search API [1] (third-party module)
  * Version: 7.x
  * Date: 2012-May-23
  * Security risk: Moderately critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

CVE: Requested
This module enables you to build searches using a wide range of features,
data sources and backends.

The module doesn't sufficiently sanitize user input in some cases when
throwing exceptions or logging errors. This enables attackers to insert
arbitrary data into a page by manipulating its URL. Users would have to open
such a manipulated URL to see the changed content.

This is only possible in some setups of Search API, specifically when users
can manually enter field identifiers in some way – e.g., through an exposed
Views sort or with the old Facets module.

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * Search API 7.x-1.x versions prior to 7.x-1.1.

Drupal core is not affected. If you do not use the contributed Search API [3]
module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you use the Search API module (especially with Views, the old Facets
    module or other advanced search forms) for Drupal 7.x, upgrade to Search
    API 7.x-1.1 [4]
  * Run update.php to also ensure that previously stored log messages are
    sanitized.

Also see the Search API [5] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * Chuck D'Antonio [6]
  * Chad Oliver [7]

-------- FIXED BY  
------------------------------------------------------------

  * Thomas Seidl [8] the module maintainer

-------- COORDINATED BY  
------------------------------------------------------

  * Greg Knaddison [9] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [10].

Learn more about the Drupal Security team and their policies [11], writing
secure code for Drupal [12], and securing your site [13].


[1] http://drupal.org/project/search_api
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/search_api
[4] http://drupal.org/node/1596524
[5] http://drupal.org/project/search_api
[6] http://drupal.org/user/250704
[7] http://drupal.org/user/1959622
[8] http://drupal.org/user/205582
[9] http://drupal.org/user/36762
[10] http://drupal.org/contact
[11] http://drupal.org/security-team
[12] http://drupal.org/writing-secure-code
[13] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news () drupal org
http://lists.drupal.org/mailman/listinfo/security-news
_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

  By Date           By Thread  

Current thread:
  • [Security-news] SA-CONTRIB-2012-084 - Search API - Cross Site Scripting (XSS) security-news (May 23)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault