Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[Security-news] SA-CONTRIB-2012-073 - Glossary - Cross-Site Scripting (XSS)
From: security-news () drupal org
Date: Wed, 9 May 2012 17:49:14 +0000 (UTC)

View online: http://drupal.org/node/1569482

  * Advisory ID: DRUPAL-SA-CONTRIB-2012-073
  * Project: Glossary [1] (third-party module)
  * Version: 6.x
  * Date: 2012-May-09
  * Security risk: Moderately critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

The glossary module scans posts for glossary terms, adding an indicator. By
hovering over the indicator, users may learn the definition of that term.

The module does not sufficiently sanitize the taxonomy information. This
leaves sites vulnerable to Cross-Site Scripting attacks.

This vulnerability is mitigated by the fact that an attacker must have a role
with permissions to create or edit taxonomy terms.

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * Glossary 6.x-1.x versions prior to 6.x-1.8.

Drupal core is not affected. If you do not use the contributed Glossary [3]
module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you use the Glossary module for Drupal 6.x, upgrade to Glossary 6.x-1.8
    [4].

Also see the Glossary [5] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * Dylan Wilder-Tack [6] of the Drupal Security Team

-------- FIXED BY  
------------------------------------------------------------

  * Nancy Wichmann [7] the module maintainer
  * Chris Hales [8]

-------- COORDINATED BY  
------------------------------------------------------

  * Forest Monsen [9] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [10].

Learn more about the Drupal Security team and their policies [11], writing
secure code for Drupal [12], and securing your site [13].


[1] http://drupal.org/project/glossary
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/glossary
[4] http://drupal.org/node/1568156
[5] http://drupal.org/project/glossary
[6] http://drupal.org/user/96647
[7] http://drupal.org/user/101412
[8] http://drupal.org/user/347249
[9] http://drupal.org/user/181798
[10] http://drupal.org/contact
[11] http://drupal.org/security-team
[12] http://drupal.org/writing-secure-code
[13] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news () drupal org
http://lists.drupal.org/mailman/listinfo/security-news

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/


  By Date           By Thread  

Current thread:
  • [Security-news] SA-CONTRIB-2012-073 - Glossary - Cross-Site Scripting (XSS) security-news (May 09)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]