Home page logo
/

metasploit logo Metasploit mailing list archives

msfgui
From: JWohlberg at towson.edu (Wohlberg, Jonathan M.)
Date: Fri, 9 Feb 2007 12:53:48 -0500

Thanks for the help. I had all of the dependencies installed. The file that Fab sent fixed the problem.

Again thanks and thanks for a great product.
Jon


-----Original Message-----
From: H D Moore [mailto:hdm at metasploit.com] 
Sent: Friday, February 09, 2007 11:42 AM
To: framework at metasploit.com
Subject: Re: [framework] msfgui

The dependencies for msfgui are:

gtk+ 2.10.x
glade2
ruby-gtk2
ruby-gnome2
ruby-glade2

On Gentoo, you can grab all of these packages with the following command:

# emerge gtk+ libglade ruby-gtk2 ruby-gnome2 ruby-libglade2

My development system has the following versions:
[ebuild   R   ] x11-libs/gtk+-2.10.7-r1
[ebuild   R   ] gnome-base/libglade-2.6.0
[ebuild   R   ] dev-ruby/ruby-gtk2-0.16.0
[ebuild   R   ] dev-ruby/ruby-gnome2-0.16.0
[ebuild   R   ] dev-ruby/ruby-libglade2-0.16.0-r1 (-r1 is important!)

-HD

On Friday 09 February 2007 10:15, Wohlberg, Jonathan M. wrote:
Unfortunatley my Ruby is not that great so any help would be
appreciated. I am running ruby version ruby 1.8.5 (2006-12-04
patchlevel 2) [i386-linux]


  By Date           By Thread  

Current thread:
  • msfgui Wohlberg, Jonathan M. (Feb 09)
    • msfgui H D Moore (Feb 09)
      • msfgui Wohlberg, Jonathan M. (Feb 09)
    • msfgui Fab (Feb 09)
      • msfgui Wohlberg, Jonathan M. (Feb 09)
      • msfgui Wohlberg, Jonathan M. (Feb 09)
        • msfgui Fabrice MOURRON (Feb 09)
    • msfgui Mathew Rowley (Feb 09)
      • msfgui Mathew Rowley (Feb 09)
      • msfgui Wohlberg, Jonathan M. (Feb 09)
    • <Possible follow-ups>
    • msfgui L.vd.Eijk at mindef.nl (Feb 14)
      • msfgui Farbrice MOURRON (Feb 14)
    • MSFGUI pikachu pokemon (Mar 26)
  • (Thread continues...)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]