Home page logo
/

metasploit logo Metasploit mailing list archives

inability to start msfweb
From: mmiller at hick.org (mmiller at hick.org)
Date: Sat, 3 Mar 2007 13:15:32 -0800

You have an SVN conflict.  Try removing the file producing the error and
then running svn update again.  If you continue to get errors of this
manner, download a fresh SVN snapshot.

On Sat, Mar 03, 2007 at 08:27:10PM +0530, Spurgeon wrote:
Hi list,

on FC6, attempt to run msfweb yields
=====================================================================================================
[root at spurgeons msf3]# ./msfweb
./script/../config/boot.rb:28:Warning: require_gem is obsolete.  Use gem 
instead.
=> Booting WEBrick...
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require': ./script/../config/../config/environment.rb:9: syntax 
error (SyntaxError)
<<<<<<< .mine
  ^
./script/../config/../config/environment.rb:11: syntax error
=======
   ^
./script/../config/../config/environment.rb:13: syntax error
.r4487
  ^     from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in 
`new_constants_in'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/servers/webrick.rb:52
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in 
`new_constants_in'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/server.rb:39
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in 
`new_constants_in'
        
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in 
`require'
        from script/server:3
=======================================================================================

Can someone pls gimme some solution to get msfweb up and running on fc6?

Thank you.

Regards.



  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]