Home page logo
/

metasploit logo Metasploit mailing list archives

Metasploit 3.0 for Windows Test Installer
From: kim at bufferzone.dk (Kim Guldberg)
Date: Sat, 24 Mar 2007 21:28:24 +0100

HI HD

On my Vista machine the install process apparently run smoothly at 
first. The Metasploit web page comes up (127.0.0.1:55555) but then it 
freezes up and nothing happens after this.

Vhen I try to start the menu points, only the Metasploit menu point gets 
me anywhere but the web page still freezes up. I getthe following warning


[*] Starting msfweb v3.0-beta-dev on http://127.0.0.1:55555/

./script/../config/boot.rb:28:Warning: require_gem is obsolete.  Use gem 
instead
.
=> Booting WEBrick...
=> Rails application started on http://127.0.0.1:55555
=> Ctrl-C to shutdown server; call with --help for options
[2007-03-24 21:27:02] INFO  WEBrick 1.3.1
[2007-03-24 21:27:02] INFO  ruby 1.8.5 (2006-08-25) [i386-mswin32]
[2007-03-24 21:27:02] WARN  TCPServer Error: Bad file descriptor - bind(2)
D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/utils.rb:73:in `init
ialize': Bad file descriptor - bind(2) (Errno::EBADF)
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/utils.r
b:73:in `new'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/utils.r
b:73:in `create_listeners'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/utils.r
b:70:in `each'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/utils.r
b:70:in `create_listeners'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/server.
rb:75:in `listen'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/server.
rb:63:in `initialize'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/1.8/webrick/httpser
ver.rb:24:in `initialize'
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/gems/1.8/gems/rails
-1.2.2/lib/webrick_server.rb:58:in `new'
         ... 12 levels...
        from D:/Program 
Files/Metasploit/Framework3/lib/ruby/gems/1.8/gems/activ
esupport-1.4.1/lib/active_support/dependencies.rb:495:in `require'
        from ./script/server:3
        from D:/Program 
Files//Metasploit/Framework3/framework/msfweb:81:in `loa
d'
        from D:/Program Files//Metasploit/Framework3/framework/msfweb:81
Press any key to continue . . .

Please tell me if this is of any use to you

Regards
Kim Guldberg



  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]