Home page logo
/

metasploit logo Metasploit mailing list archives

ruby-lorcon build problem
From: hdm at metasploit.com (H D Moore)
Date: Sun, 25 Mar 2007 02:47:35 -0500

The ruby-lorcon library has been updated to use the new API:

/tools/tx-80211 $ svn info
Path: .
URL: https://www.nycccp.net/svn/tx-80211
Repository Root: https://www.nycccp.net/svn/tx-80211
Repository UUID: 9df7839b-55f0-0310-a85b-d1782bffedff
Revision: 134
Node Kind: directory
Schedule: normal
Last Changed Author: jwright
Last Changed Rev: 134
Last Changed Date: 2007-03-22 07:40:13 -0500 (Thu, 22 Mar 2007)

/tools/tx-80211 $ ./configure && make 
/tools/tx-80211 # make install

ruby-lorcon # ruby extconf.rb
checking for tx80211_txpacket() in -lorcon... yes
creating Makefile

ruby-lorcon # make
i686-pc-linux-gnu-gcc -I. -I. -I/usr/lib/ruby/1.8/i686-linux -I.  -fPIC -O2 -march=pentium4  -fPIC  -c 
Lorcon.c
i686-pc-linux-gnu-gcc -shared  -L'/usr/lib' -Wl,-R'/usr/lib' -o Lorcon.so 
Lorcon.o  -Wl,-R -Wl,/usr/lib -L/usr/lib -L. -lruby18 -lorcon  -ldl -lcrypt -lm   -lc

ruby-lorcon # make install
/bin/install -c -m 0755 Lorcon.so /usr/lib/ruby/site_ruby/1.8/i686-linux

-HD

On Tuesday 20 March 2007 10:49, Andrew Sussex wrote:
I've installed Lorcon from SVN but ruby-lorcon refuses to build:

ruby-lorcon# ruby extconf.rb
checking for tx80211_txpacket() in -lorcon... no
Error: the lorcon library was not found, please see the README
ruby-lorcon#



  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]