Home page logo
/

metasploit logo Metasploit mailing list archives

Re: Bare-minimum requirements to run metaspoilt
From: Jacky Jack <jacksonsmth698 () gmail com>
Date: Fri, 7 May 2010 00:11:32 +0800

On Thu, May 6, 2010 at 11:55 AM, HD Moore <hdm () metasploit com> wrote:
On 5/5/2010 10:33 PM, Jacky Jack wrote:
In one of my previous pentests, I found 2 sessions exploiting via VMWare.
Then metasploit hangs. I had to kill it and re-run it and no sessions
found any more whenever
I run again and again.


That may be a Metasploit bug, but its not a VMWare bug. The exception is
VMWare in host-only or NAT mode networking; both of these have trouble
with most security tools, including Metasploit.

I don't think this is Metasploit bug while I was able to run direct
connection with dedicated PC with no problem.
Host-Only work well or best for connection among Host and other VMwares.
NAT-Mode should never be  used for pentest.
Bridged mode is the only one we should use.
I faced such error in such Bridged mode.

My host OS is XP and I run BT in VMware.
I guessed the max connection limit was exceeded for the host OS to
send such attack traffic to the target I was testing.
Later I thought I needed to do registry hack for XP to increase
concurrent connection limits and not so sure if this would or not.



-HD

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]