Home page logo
/

metasploit logo Metasploit mailing list archives

Re: How to get postgres driver installed in Windows
From: Raúl Millán <raul () cdsi com pa>
Date: Fri, 14 May 2010 12:18:59 -0500

Just tried it in Ubuntu, got a completely different error … any help will be
appreciated.

 

From: Raúl Millán [mailto:raul () cdsi com pa] 
Sent: Friday, May 14, 2010 12:03 PM
To: 'Framework () spool metasploit com'
Subject: How to get postgres driver installed in Windows

 

Hi everyone, I’m trying to get the postgres driver working in metasploit
(r3297) installed in Windows 7 64 bits.  When ever I try to install it
returns the following error:

 

[*] exec: gem install postgres

 

Building native extensions.  This could take a while...

ERROR:  Error installing postgres:

        ERROR: Failed to build gem native extension.

 

/usr/bin/ruby.exe extconf.rb install postgres

 

 

Gem files will remain installed in
/usr/lib/ruby/gems/1.9.1/gems/postgres-0.7.9.2008.01.28 for inspection.

Results logged to
/usr/lib/ruby/gems/1.9.1/gems/postgres-0.7.9.2008.01.28/ext/gem_make.out

Updating class cache with 625 classes...

 

I already have postgres up and running, just waiting for the connection from
metasploit.

 

I have like 0 experience with Ruby (I’m no programmer) and I depend on my
Windows 7 for everyday work (don’t have any other machine available).  I’ll
will be trying this in a Ubuntu VM later, but I really need it working on
Windows 7.

 

If any of you have any previous experience with this or know a URL where I
can point my browser to, I’d be very thankful.

 

-RM

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]