Home page logo
/

metasploit logo Metasploit mailing list archives

Re: How to get postgres driver installed in Windows
From: Raúl Millán <raul () cdsi com pa>
Date: Sat, 15 May 2010 08:48:13 -0500

Well $ gem install postgres-pr actually executes successfully, but when I
try to list the drivers available with db_driver command I only see SQLite3
listed.

The logs @
/usr/lib/ruby/gems/1.9.1/gems/postgres-0.7.9.2008.01.28/ext/gem_make.out
only have this:

/usr/bin/ruby.exe extconf.rb install postgres

Cygwin install was handled by the metasploit install .exe, haven't done
anything out of the ordinary to it.

Anyway I think that 3.4 is close enough for me to wait.

Thanks everyone.

-RM

-----Original Message-----
From: framework-bounces () spool metasploit com
[mailto:framework-bounces () spool metasploit com] On Behalf Of HD Moore
Sent: Friday, May 14, 2010 14:44 PM
To: framework () spool metasploit com
Subject: Re: [framework] How to get postgres driver installed in Windows

You can try the pure-ruby driver and see if it works for you:

$ gem install postgres-pr

Otherwise, you will need to sort out your build environment issues under
Cygwin or wait for the 3.4.0 installer, which will hopefully have the
native pg driver included.

-HD

On 5/14/2010 12:02 PM, Raúl Millán wrote:
Hi everyone, I’m trying to get the postgres driver working in metasploit
(r3297) installed in Windows 7 64 bits.  When ever I try to install it
returns the following error:

 

[*] exec: gem install postgres

 

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]