Home page logo
/

metasploit logo Metasploit mailing list archives

Re: svn up error
From: George Karagiannidis <redsolja () gmail com>
Date: Tue, 22 Jun 2010 21:53:18 +0300

On Tue, Jun 22, 2010 at 9:26 PM, Nicolas Krassas <krasn () ans gr> wrote:
Use one directory the one that is more convenient to you, and link the other
one if there is a need to have it in the system.

-----Original Message-----
From: framework-bounces () spool metasploit com
[mailto:framework-bounces () spool metasploit com] On Behalf Of George
Karagiannidis
Sent: Tuesday, June 22, 2010 9:22 PM
To: Robin Wood
Cc: framework () spool metasploit com
Subject: Re: [framework] svn up error

On Tue, Jun 22, 2010 at 9:16 PM, Robin Wood <robin () digininja org> wrote:
On 22 June 2010 19:10, George Karagiannidis <redsolja () gmail com> wrote:
On Tue, Jun 22, 2010 at 8:11 PM, Robin Wood <robin () digininja org> wrote:
On 22 June 2010 18:08, George Karagiannidis <redsolja () gmail com> wrote:
I did an "svn up" command and i interrupted it with ctrl+c.
Now whenever i do an "svn up" i get the following error that i dont
know how to fix:
svn: Working copy '.' locked
svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for
details)

# svn cleanup
svn: In directory '.'
svn: Error processing command 'modify-wcprop' in '.'
svn: 'HACKING' is not under version control

I got BT4 and my working directory is /pentest/exploits/framework3/


Delete the framework3 directory and do a clean checkout from the msf
site. Its the easiest way to fix this type of svn problem.

Robin


What i did was to remove the framework3 directory, and then svn co
https://www.metasploit.com/svn/framework3/trunk framework3 i have
revision 9581

now when i enter the msfconsole, it sais:
svn r9579 updated 164 days ago (2010.01.09)

my svn up doesnt update anything.

Any help is appreciated,
Thank you
--
Never Quit


9581 is the latest version, are you running from the right directory?

Robin


That has been my question for quite some time and i forgot about it:(

i run/upgrade metasploit from the folder /pentest/exploits/framework3 when i
enter the msfconsole it sais the all the things i said in the previous mail
BUT

there is a directory /opt/metasploit3/msf3/ where when i do the svn up it
still pops this error for me to do an svn cleanup.

I am really confused:S because all this time those 2 paths seemed to be
synced.

Thank you

--
Never Quit
_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework



Well it is true there is no real practical need for me to have both
directories but
i do not like to get this false error that my msf is not updated at
all, and since
this is just a misconfiguration from my side, i just want to solve it =[.

BTW you mean linking the /opt/... with the
/pentest/exploits/framework3/ folder since
this is the one im going to use?
Thank you for your help.
-- 
Never Quit
_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault