Home page logo
/

metasploit logo Metasploit mailing list archives

Re: postgres on OS X
From: Robin Wood <robin () digininja org>
Date: Mon, 11 Apr 2011 17:33:03 +0100

On 11 April 2011 17:24, Jonathan Cran <jcran () metasploit com> wrote:
On 04/11/2011 05:52 AM, Robin Wood wrote:

After a struggle I've got Postgres 9.1 installed in OS X via ports and
now I'm trying to get the pg Ruby gem installed but when I do it
complains about libpq-fe.h being missing.

That should come from libpq but the only ports package I can find is
libpqxx which wants to start installing Postgresql 8.4.

Is it possible to get this up and running from ports or should I give
up and go to a source install?


I've had success installing from source. Also, make sure that the headers
are in your path (may be the problem with the ports install).

export PATH=/opt/local/lib/postgresqlXX/bin/:$PATH
gem install pg

Ye, sorry forgot to reply, Carlos pointed out the same solution and I
got it working in the end.

Robin



jcran



--
Jonathan Cran
Metasploit Team
jcran () rapid7 com
515.890.0070

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault