Home page logo
/

metasploit logo Metasploit mailing list archives

Re: guidence required in installing mysql in metasploit
From: Linan Wang <wang.linan () gmail com>
Date: Tue, 14 Jun 2011 10:54:32 +0100

yes, actually i think metasploit folks prefer postgres over mysql. to
configure postgres:
https://community.rapid7.com/docs/DOC-1268
what i found is there is no need to download the pro package. only svn the
msf3 directory and use mysql/postgres of your own system.

On Tue, Jun 14, 2011 at 10:26 AM, jambunathan sadasivamiyer <
jamshuttle77 () gmail com> wrote:

hi
thanks for sending links
i am getting following error with mysql

Database not connected
msf > db_connect root:userx () 127 0 0 1/msf3
[-] Error while running command db_connect: Failed to connect to the
database: uninitialized constant MysqlCompat::MysqlRes
Call stack:
/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1841:in
`db_connect_mysql'
/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1724:in `cmd_db_connect'
/msf3/lib/rex/ui/text/dispatcher_shell.rb:376:in `run_command'
/msf3/lib/rex/ui/text/dispatcher_shell.rb:338:in `block in run_single'
/msf3/lib/rex/ui/text/dispatcher_shell.rb:332:in `each'
/msf3/lib/rex/ui/text/dispatcher_shell.rb:332:in `run_single'
/msf3/lib/rex/ui/text/shell.rb:143:in `run'
msfconsole:130:in `<main>'
what does it mean

if postgresql is installed by default in metaploit ,

is there any way to select posgresql instead of  mysql

guide me please

jambunathan.ms


On Tue, Jun 14, 2011 at 2:10 PM, Linan Wang <wang.linan () gmail com> wrote:

hi,
i'm new too. seems nobody here in this list takes care of new comers :(
here is the page for db_*.

http://www.offensive-security.com/metasploit-unleashed/Configuring_Databases


  On Tue, Jun 14, 2011 at 9:27 AM, jambunathan sadasivamiyer <
jamshuttle77 () gmail com> wrote:

  From: jambunathan sadasivamiyer <jamshuttle77 () gmail com>
To: framework-request () spool metasploit com
Date: Tue, 14 Jun 2011 13:43:11 +0530
Subject: guidence required in installing mysql in metasploit
hi
I am  a newbie

i am currently working  with Metasploit 3.0

i installed metasploit 3.0 and executed update
now it is 3.8

whether mysql or postgressql is mandatory for this metasploit?
if so ,  how to do that,
if i execute
msf> db_driver
i am getting current mysql
it is asking for mysqladmin and mysql to be installed,
how i should do that.

can  any body guide in this


thanks
jambunathan.ms


--

Jambu

_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework




--
Best regards

Linan Wang




--

Jambu




-- 
Best regards

Linan Wang
_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]