Home page logo
/

metasploit logo Metasploit mailing list archives

Re: error message on msfupdate cannot determine checkout type
From: Chip <jeffschips () gmail com>
Date: Tue, 08 Jan 2013 23:46:00 -0500

Well, ok, now I'm confused:

If I go to the standard metasploit download site
ww.metasploit.com/download and follow the instructions here:

https://community.rapid7.com/docs/DOC-1776 which shows an example
install process using the same name as the file I downloaded.

Notice the word "community" in the URL which leads me to believe this
should be the community branch, and follow the instructions here, I am
left with a directory entitled metasploit-4.5.0, that contains a file
called msfpro -- so why am I getting the msfpro version from a comminty
download link?  As well, the directory that is created does not contain
the usual files such as msfconsole, msfpudate,etc.

Okay, so I run the mspro file for the first time and get a long, long
printout of lines that say:

NOTICE: CREATE TABLE /PRIMARY KEY  will create implicit sequence . . . .

Then finally an msfconsole prompt.

I'm simply trying to get the latest community version of metasploit --
why can't I easily find a suitable link for the "community" version
anywhere?

Any help for this duffus much appreciated.



On 1/8/2013 5:28 PM, Joshua Smith wrote:
Jeff, are you trying to setup a full development environment?  If not,
just use the installer.  rm -rf the /opt/metasploit dir and run the
installer.

If you want a full dev env, follow this:
 https://github.com/rapid7/metasploit-framework/wiki/Metasploit-Development-Environment

-Josh

On Jan 8, 2013, at 4:22 PM, Chip wrote:

I just followed the directions on the metasploit site, here:

https://community.rapid7.com/docs/DOC-1268

Perhaps someone can check out if that is a valid (or best site to
download from?) download site?

Thank you.


On 1/8/2013 4:23 PM, Joshua Smith wrote:
Chip, is this the first time this machine has been updated in a
while?  The updater was changed to use git, and maybe if you didn't
get an updated msfupdate, it could be jacked up, however I don't
think they shutdown the svn server yet so... someone else on here
will know.  You could  try updating svn, apt-get update && apt-get
install svn I think, if it's out of date.  Just spitballin tho.

-Josh

On Jan 8, 2013, at 3:14 PM, Chip wrote:

Hello.

I'm receiving the following error message when I attempt to do an
msfupdate of metasploit v4.5.0-release [core:4.5 api:1.0] on a
backtrack 5 r3 machine:

./msfupdate:156:in '<main>': Cannot determine checkout type: '.'
(RuntimeError)

Any hints on why this may be happening or how to correct?

Thank you.
_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework



_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework



_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]