Home page logo
/

metasploit logo Metasploit mailing list archives

Re: homebrew build problems
From: fred concklin <fredconcklin () gmail com>
Date: Tue, 2 Apr 2013 11:37:21 -0700

Thanks, I had rvm installed and was using ruby-2.0.0-p0.

For posterity:

    $ rvm use 1.9.2

fixed the problem.


On Tue, Apr 2, 2013 at 11:32 AM, Carlos Perez <carlos_perez () darkoperator com
wrote:

I would open a ticket with them, they also now push Ruby 2.0 as default
and that has problems with OpenSSL loading in Metasploit so you are forced
to use chruby or RVM

On Apr 2, 2013, at 2:25 PM, fred concklin <fredconcklin () gmail com> wrote:

Hi,

I have a feeling this might not be the right place, but I'm experiencing
problems running msfupdate installed through homebrew.

$ brew install metasploit
$ msfupdate

[*]
[*] Attempting to update the Metasploit Framework...
[*]

/usr/local/bin/msfupdate:190:in `<main>': Cannot determine checkout
type: `/usr/local/Cellar/metasploit/4.5.0-2013021301/libexec' (RuntimeError)

If anybody has come across this I'd appreciate input, otherwise I'll
start looking into the homebrew formula / rvm communities for a fix.


_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework


_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault