Home page logo
/

nanog logo nanog mailing list archives

Re: IPv6: IS-IS or OSPFv3
From: Justin Shore <justin () justinshore com>
Date: Mon, 05 Jan 2009 11:43:25 -0600

Kevin Oberman wrote:
I would hope you have a backbone well enough secured that you don't need
to rely on this, but it does make me a bit more relaxed and makes me
wish we were using ISIS for IPv4, as well. The time and disruption
involved in converting is something that will keep us running OSPF for
IPv4 for a long time, though. I remember the 'fun' of converting from
IGRP to OSPF about 13 years ago and I'd prefer to retire before a
repeat.

I did the OSPF --> IS-IS migration some time back and here's some of the info I found at the time.

http://www.nanog.org/meetings/nanog29/abstracts.php?pt=Njg2Jm5hbm9nMjk=&nm=nanog29

Vijay did a nice presentation on AOL's migration to IS-IS. IIRC AOL migrated everything in 2 days. Day 1 was to migrate their test POP and hone their script. All remaining POPs were migrated on Day 2. I believe he said it went well. There have been several other documented migrations too:

http://www.geant.net/upload/pdf/GEANT-OSPF-to-ISIS-Migration.pdf
http://www.ripe.net/ripe/meetings/ripe-47/presentations/ripe47-eof-ospf.pdf

I migrated my SP from a flat OSPF network (end to end area 0) to IS-IS. The OSPF setup was seriously screwed up. Someone got the bright idea to changes admin distances on some OSPF speakers, introduce a default in some places with static defaults in others, redistributing like it was going out of style, redisting a static for a large customer subnet on P2 instead of P1 which is what PE1 actually connected to (and not advertising the route from PE1 for some unknown reason), etc. The old setup was a nightmare.

The IS-IS migration went fairly well after I got some major bugs worked out on our 7600s. I implemented IS-IS overtop of OSPF. Some OSPF speakers had admin distances of 80 and some were default. IS-IS slipped in over top with no problems. I raised IS-IS to 254 for the initial phase anyway just to be safe. Once I had IS-IS up I verified it learned all the expected routes via IS-IS. Then I lowered its admin distance back to the default and bumped OSPF up to 254. Shortly thereafter I nuked OSPF from each device. It was hitless. I never could get IS-IS to work with multiple areas. The 7600s made a smelly mess on the CO floor every time I tried. In the end I went with a L2-only IS-IS network. Still it works well for the most part. I've had about as much trouble with IS-IS as I have had with OSPF. Occasionally some random router will get a burr under it's saddle and jack up the MTU on the CLNS packets beyond the interface's max. The receiving router will drop the padded frame as too big. Fixing this can sometimes happen with a shut/no shut. Sometimes I can nuke the entire IS-IS config and re-add the config. Other times I simply have to reboot. This doesn't happen too often; it's usually several hours after I rock the IS-IS boat so to speak. Still, I wouldn't go back to OSPF for this SP.

Justin


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]