Home page logo
/

nanog logo nanog mailing list archives

Speedtest Results speedtest.net vs Mikrotik bandwidth test
From: "Lorell Hathcock" <lorell () hathcock org>
Date: Mon, 1 Apr 2013 19:19:15 -0500

All:

 

I am having some speedtest results that are difficult to interpret.

 

I am a small WISP multi-homed with Cogent and Level 3 in Houston, TX.  I am
running BGP with each with 100 Mbps+ on each link.

 

Some of my customers have begun complaining that they are not getting the
proper speeds.  They are using speedtest.net and/or speakeasy.net to test
the results.

 

My network is Mikrotik based and as such, I have access to Mikrotik's
built-in bandwidth testing.

 

With a laptop on site, running against speedtest.net (which kicked me over
to the Comcast speedtest server instance) I can only get 4 Mbps up and 1.5
Mbps down.  That is consistent on their desktops too.  We eliminated their
routing equipment and other consumers of the bandwidth and tested and got
similar results.

 

But when  we run the Mikrotik bandwidth tests (even to off-net Mikrotik
devices in Hawaii and Mission, TX) we get 25+ Mbps synchronous.

 

We have run traceroutes to various traceroute servers and they go through
Cogent and/or Level 3.  For the most part it does not seem to matter which
path it takes, the bandwidth seems to be about the same going both routes.

 

When we run the laptop-based btest.exe against Mikrotik bandwidth test
servers, the laptop got significantly better results (14 Mbps) , but not 25+
Mbps.

 

It is almost like there is a Java based problem with speedtest.net.

 

Thoughts?

 

Thanks,

 

Lorell Hathcock

 


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault