Home page logo
/

Nmap Announce mailing list archives

nmap+V 1.01, Fixed "Broken Pipe" Bug
From: "Jay Freeman \(saurik\)" <saurik () saurik com>
Date: Mon, 15 May 2000 13:26:48 -0500

nmap-type people:

Turned out to be a stupid error I introduced last night while cleaning up
the code to minimize changes to nmap :-(.  I was scanning _all_ versionable
ports, not just the ones found open.  So if nmap found that you weren’t
running a news server, it would connect to it anyway to try to figure out
what version it was.  I have fixed this, and the new version is at
ftp://ftp.saurik.com/pub/nmap/nmap+V .  And no, I didn’t just solve it by
removing the lines that generate the error… although it sure does look like
that:-).  Oh, and I was feeling extra silly this morning, so I made a small
change to the CHANGELOG file in the patch as well.

Oh, and to satisfy all the people who were e-mailing me having no idea how
to use patch:

wget http://www.insecure.org/nmap/dist/nmap-2.53.tgz
tar -zxf nmap-2.53.tgz
cd nmap-2.53
wget ftp://ftp.saurik.com/pub/nmap/nmap+V
patch -p1 < nmap+V

Or, if you are feeling extra lazy (or have a strange version of patch, a
Solaris machine I was going to try it on to make sure my configure
modifications worked (still haven’t done that, probably later today) refused
to run the patch…) you can just get a new tarball from
ftp://ftp.saurik.com/pub/nmap/nmap-2.53+V-1.01.tgz .

Sincerely,
Jay Freeman (saurik)
saurik () saurik com <mailto:saurik () saurik com>




  By Date           By Thread  

Current thread:
  • nmap+V 1.01, Fixed "Broken Pipe" Bug Jay Freeman \(saurik\) (May 15)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]