Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: performance issues
From: BlackHat.Info <blackhat () needguide com>
Date: 3 Apr 2002 03:33:34 -0800

huh?

In my case, I've noticed fast scan performance averages ~300 seconds compare to BETA31 ~500secs. See nmap in action in 
www.blackhat.info project.

Cheers.


On Tue, 02 April 2002, "Andy Lutomirski" wrote:


Here's a good one:

I run nmap -sS -P0 -n -r -v -d -d -p1-1000 <win2k box on local ethernet>, and it takes awhile.  The debug shows that 
retries are needed.  If I add --scan_delay 1, no (or very few) packets are dropped, and the scan completes much 
faster.  I get the fastest results with --max_parallelism 1 (w/o scan_delay), but --max_parallelism 2 does not have 
nearly the same effect.

If I add --win_norawsock, then the speeds are much increased without either max_parallelism or scan_delay, for 
--max_parallelism 1 is still the fastest.

To add insult to injury, port 389 comes up filtered if and only if I do not set --win_nor (so that sends are over 
real raw sockets).

WTF is happening?

Andy Lutomirski

-------------------------------
www.blackhat.info
"just discovering insecurity"
-------------------------------

---------------------------------------------------------------------
For help using this (nmap-dev) mailing list, send a blank email to 
nmap-dev-help () insecure org . List run by ezmlm-idx (www.ezmlm.org).



  By Date           By Thread  

Current thread:
  • Re: performance issues BlackHat . Info (Apr 03)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]