Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Fix for WinPcap 3.1
From: Andy Lutomirski <luto () stanford edu>
Date: Sun, 22 Feb 2004 17:47:02 -0800

I don't love this test for Unicode -- it will false-positive if there is a single-character name and will probably overread the buffer. If anyone knows a clean way to find winpcap's version, that would help. Also, in a release or two, we should probably remove the extra tracing.

On the other hand, it does work.  Thanks.

--Andy

Fyodor wrote:
On Sat, Feb 21, 2004 at 12:08:08PM +0100, Gisle Vanem wrote:

With the new WinPcap 3.1 beta, nmap has stopped working.
This is really the fault of the 'Italian mob' since the adapter names are now
returned as ASCII even under Win-NT+. Here's an easy patch:


Thanks for noting the problem and sending a patch!  I don't know much
about WinPcap adapter naming, but your patch appears to retain
backward compatibility so that previous versions of WinPcap will still
work with Nmap.  So unless anyone objects to this patch, I will
apply it for the next version of Nmap.

Cheers,
-F

---------------------------------------------------------------------
For help using this (nmap-dev) mailing list, send a blank email to nmap-dev-help () insecure org . List archive: http://seclists.org



---------------------------------------------------------------------
For help using this (nmap-dev) mailing list, send a blank email to nmap-dev-help () insecure org . List archive: http://seclists.org



  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault