Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Nmap 3.81: warning accompanies netmask /1
From: Fyodor <fyodor () insecure org>
Date: Fri, 22 Apr 2005 20:52:22 -0700

On Tue, Feb 08, 2005 at 10:44:18AM -0500, Justin Cranford wrote:
I get a warning with all versions of nmap (including 3.81) when I run
this command:

   nmap 10.0.0.0/1


I don't know how useful that command is, since it covers 2,147,483,648
IPs.  I hope you have a long time to wait for results :).  Also, as
someone else on nmap-dev mentioned, the 10 is kinda pointless for
anything below /4.  0.0.0.0/1 scans the same IPs.

I looked into the issue though, and found and integer overflow.  I
changed TargetGroup::ipsleft from an int into an unsigned long and that
command now works appropriately.  The change will be in the next version.

/0 still doesn't work, so I added an error message if someone tries it.

Cheers,
-F


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev


  By Date           By Thread  

Current thread:
  • Re: Nmap 3.81: warning accompanies netmask /1 Fyodor (Apr 23)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]