Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: 4.0 Segfault
From: Fyodor <fyodor () insecure org>
Date: Fri, 3 Feb 2006 13:01:04 -0800

On Fri, Feb 03, 2006 at 11:28:22AM -0700, Leif Tishendorf wrote:
With the latest 4.0 release I am getting a segfault when I am
scanning more then one host at a time.  Did a strace and got:

--- SIGSEGV (Segmentation fault) @ 0 (0) ---
write(2, "caught SIGSEGV signal, cleaning "..., 35caught SIGSEGV signal, cleaning up) = 35
close(1)                                = 0
munmap(0xb7f67000, 4096)                = 0
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
write(3, "The SYN Stealth Scan took 625.25"..., 2577) = 2577
tgkill(2840, 2840, SIGABRT)             = 0
--- SIGABRT (Aborted) @ 0 (0) ---
+++ killed by SIGABRT +++

I'm running the following scan:

/usr/local/nmap-4.00/nmap -vvvv --host_timeout 1500000 -oN - -oX <xml out> -sS -p 1-18,20-9099,9101-65535 -O <host>

Could you try it with gdb instead?  Go to (or remake) the source
directory, 'make' Nmap, then do:

gdb ./nmap
r -vvvv --host_timeout 1500000 -oN - -oX <xml out> -sS -p 1-18,20-9099,9101-65535 -O <host>
[ wait for crash, then press 'bt<enter>' ]

Then would you send us a log of the output?  If it is very long,
sending just the 'bt' results may be enough.

Thanks,
Fyodor


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault