Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: [PATCH] nmapfe: Another patch migrating from deprecated APIs
From: Fyodor <fyodor () insecure org>
Date: Fri, 20 Jan 2006 13:08:37 -0800

On Fri, Jan 20, 2006 at 10:32:32PM +0200, Priit Laes wrote:

This patch gets rid of the deprecated combobox API and also kills all
the Gtk-Critical error messages :)


nmap-0.96b1-gtk2-migration-part3.patch
    * Migrated the last of the comboboxes to the new GtkComboBox API.
    * Fixed the Gtk-Critical error message.

Hmm.  You sent part1.patch on the 12th and this is part3.  There is a
part2.patch on your web site, which seems to be required to apply
part3 cleanly.  So I have applied that for the next version of Nmap.

I'm very glad to hear about removal of the Gtk-Critical errors!  But
part3 includes a new call to gtk_combo_box_set_row_separator_func,
which is a new symbol to GTK 2.6
(http://www.gtk.org/api/2.6/gtk/ix05.html).  Do you think you could
modify the patch to avoid that call so that it will compile on systems
that don't yet have 2.6 (probably the majority of existing systems)?

Thanks,
Fyodor


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault