Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: [PATCH]: nmapfe: builds now with GTK_DISABLE_DEPRECATED :)
From: Fyodor <fyodor () insecure org>
Date: Fri, 20 Jan 2006 13:55:45 -0800

On Fri, Jan 20, 2006 at 11:06:54PM +0200, Priit Laes wrote:
Hello,

I finally succeeded :) nmapfe doesn't use any deprecated APIs anymore :)

nmap-0.96b1-gtk2-migration-part4.patch
    * Replaced deprecated functions with approriate non-deprecated
f-ns.

Fabulous!  With this, plus the compatability patch you just mailed me
(http://amd.store20.com/files/2006-Q1/nmap-gtk-2-4-compatibility.diff),
NmapFE compiles and runs on my system with none of those annoying
warnings at all.  Yay!

The only part of your patch I didn't apply was the configure.ac change
to add "-DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED" to the
compilation line.  That is a great option for testing to ensure no
deprecated API calls are used, but I don't want to add it to the
distributed NmapFE because I don't want NmapFE to immediately break
the next time they deprecate some call that it uses.  I'd rather have
the deprecation period for some time to fix it.

Thanks,
Fyodor


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault