Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: build warning: umit_py2exe: Version Info will not be included
From: jah <jah () zadkiel plus com>
Date: Wed, 03 Oct 2007 22:45:24 +0100


On Wed, Oct 03, 2007 at 02:51:26PM +0100, jah wrote:
  
I get this warning at cygywin shell when building on XPSP2:

warning: umit_py2exe: Version Info will not be included:
  could not parse version number '4.22SOC6'
    

Thanks for your report. This is a harmless warning, but thanks for
bringing it to our attention. py2exe is trying parse the version number
"4.22SOC6" into a sequence of integers so it can encode them into a
Windows resource. But it can't parse that version number, so the
resource doesn't get inserted. Unfortunately, it appears from a quick
look at the py2exe source code that other resource information, such as
the product name, don't get inserted just because the version number
fails (see py2exe.build_exe.py2exe.add_versioninfo). This won't be an
issue for the next big release, which will have a more easily parseable
version number.

David Fifield

  
Nice.  Are the link warnings from nselib anything to mind?

jah
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]