Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: showHTMLTitle.nse PANIC bug on windows - Title got truncated!
From: Kris Katterjohn <katterjohn () gmail com>
Date: Wed, 14 Nov 2007 06:31:06 -0600

Fyodor wrote:
On Fri, Nov 09, 2007 at 01:40:33PM -0600, gabriel () gsource org wrote:
Running 4.22SOC8 on WinXP, i eventually get this response.


Initiating Parallel DNS resolution of 150 hosts. at 13:22
Completed Parallel DNS resolution of 150 hosts. at 13:22, 6.53s elapsed
SCRIPT ENGINE: Initiating script scanning.
Initiating SCRIPT ENGINE at 13:22
SCRIPT ENGINE Timing: About 17.02% done; ETC: 13:25 (0:02:26 remaining)
SCRIPT ENGINE DEBUG: showHTMLTitle.nse: Title got truncated!
SCRIPT ENGINE Timing: About 34.04% done; ETC: 13:25 (0:01:56 remaining)
PANIC: unprotected error in call to Lua API (C:\Program
Files\Nmap\scripts\showH
TMLTitle.nse:32: bad argument #3 to 'connect' (Sorry, you don't have
OpenSSL.))

C:\temp>

Hi Gabriel.  Thanks for the report.  I can reproduce this by script
scanning an SSL scanner from Windows (e.g. "nmap -p443 -P0 -sC -d
www.amazon.com").  One difference though is that my Nmap doesn't
crash--just that script bails out.  Presumably the same thing would
happen on Unix if compiled --without-openssl.


To confirm, --without-openssl on Linux bails but doesn't crash (I used 
your same command).

Thanks,
Kris Katterjohn

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]