Home page logo
/

nmap-dev logo Nmap Development mailing list archives

RE: 4.49RC7 NSE Loop?
From: "Thomas Buchanan" <TBuchanan () thecompassgrp net>
Date: Tue, 11 Dec 2007 15:40:03 -0600

-----Original Message-----
From: nmap-dev-bounces () insecure org 
[mailto:nmap-dev-bounces () insecure org] On Behalf Of komseh
Sent: Tuesday, December 11, 2007 3:10 PM
To: nmap-dev () insecure org
Subject: Re: 4.49RC7 NSE Loop?

I forgot to mention that i've reproduced the same error on 
two different
machines.

On Dec 11, 2007 3:07 PM, komseh <komseh () gmail com> wrote:

I think someone reported a similar bug to this recently, but I
couldn't
fix my issue using their methods.

Scanning this group of hosts together with either T2,T3, or T4 all
produce
the same output infinitely and the scan never ends.

However, nmap completes the scan without a problem if each host is
scanned
individually.

nmap -T4 -v -sS -sV -O -n --script=all --script-trace -iL test.list



I don't know if it's the same issue you're facing, but as I was trying
to track down a NSE looping issue I was seeing last week, I noticed that
a few of the scripts that I wrote don't properly close sockets on error
paths.  This was leading to resource starvation with available sockets,
which the garbage collection fix that Stoiko and Diman checked in
corrected (at least in my testing).  Anyway, here's a patch that
corrects that behavior in those scripts.  Maybe it will help.

Thomas

Attachment: nse-socket-close.patch
Description: nse-socket-close.patch


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org

  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]