Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: NPPTools.dll missing error in Vista
From: Fyodor <fyodor () insecure org>
Date: Fri, 21 Dec 2007 17:08:43 -0800

On Fri, Dec 21, 2007 at 02:02:33PM -0500, spamme () zztopping com wrote:
That was it. I completely uninstalled WinPCap and installed the one from the
winpcap.org site and it works perfectly.

I think you guess is right. That's the only thing that makes sense here. The
root cause of this may be a bit difficult.

Hmmm ... I think I may have found the problem.  While we tried to
install a different Packet.dll on Vista, it looks like
nmap/mswin32/winpcap/Packet.dll and
nmap/mswin32/winpcap/vista/Packet.dll were actually exactly the same.
David must have grabbed the wrong Vista Packet.dll while he was
upgrading to 4.02.

So I had to obtain the right Packet.dll installer for Vista.  My
machine only has 4GB of RAM, so installing Vista to do this was out of
the question.  Fortunately, David previously found and documented a
way to retrieve the Vista Packet.dll under XP using 7-zip
(nmap/mswin32/winpcap/Upgrading-Instructions.txt).

Note that the Winpcap installer seems to have a 3rd Packet.dll as
well.  I'm not sure what it is for, but we don't currently use it.  It
might be for Windows NT 4 according to the version information on the
file.

Cheers,
Fyodor


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]