Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: error compiling under OS X
From: David Fifield <david () bamsoftware com>
Date: Sun, 13 Apr 2008 19:39:22 -0600

On Thu, Apr 10, 2008 at 03:28:29PM -0700, Rodney Myers wrote:
I'm running OS X 10.5.2, XCode 3.0, and the lastest tar-ball from the  
web page.

When I type "make", it errors out with this error message;

  File "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/distutils/sysconfig.py", line 389, in 
_init_posix
    raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET  
mismatch: now "10.4" but "10.5" during configure
make[1]: *** [build-zenmap] Error 1
make: *** [all] Error 2

I'm not sure what it means either. Do you happen to have the environment
variable MACOSX_DEPLOYMENT_TARGET defined? What happens when you enter
the command

        echo $MACOSX_DEPLOYMENT_TARGET

From looking at the file sysconfig.py referenced in the error message,
it appears the error can occur only when MACOSX_DEPLOYMENT_TARGET is
defined. It might have been defined somewhere else in the build process,
or maybe some other software package defined it. Try opening a new
terminal window and building from there.

David Fifield

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault