Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Nmap/Lua Compilation Woes
From: Lionel Cons <lionel.cons () cern ch>
Date: Tue, 27 May 2008 17:12:20 +0200

Lionel Cons writes:
Linux (Red Hat Enterprise 4 derivative). But, since the library
loading also does not work (anymore), I guess the OS detection went
bad. I will continue to investigate...

Here is more information. Nmap 4.62 (tarball) compiles fine. The SVN
version (revision 7703) compiles badly.

Nmap 4.62:

$ grep 'Compiling liblua' Makefile.in 
        @echo Compiling liblua; cd $(LIBLUADIR) && $(MAKE) liblua.a @LUAFLAGS@
$ make
[...]
make[1]: Entering directory `/tmp/nmap-4.62/liblua'
gcc -O2 -Wall -g -O2 -DLUA_USE_POSIX -DLUA_USE_DLOPEN   -c -o lapi.o lapi.c

SVN revision 7703:

$ grep 'Compiling liblua' Makefile.in 
        @echo Compiling liblua; cd $(LIBLUADIR) && $(MAKE) liblua.a CC="$(CC)" MYCFLAGS="$(CFLAGS) @LUA_CFLAGS@"
$ make
[...]
make[1]: Entering directory `/tmp/svn/liblua'
gcc -O2 -Wall -g -O2 -Wall  -fno-strict-aliasing   -DHAVE_CONFIG_H -DNMAP_NAME="Nmap" -DNMAP_URL="http://nmap.org"; 
-DNMAP_PLATFORM="i686-pc-linux-gnu" -DNMAPDATADIR="/usr/local/share/nmap" -DNMAPLIBEXECDIR="/usr/local/libexec/nmap"    
-c -o lapi.o lapi.c

So the SVN version somehow does not set the LUA_CFLAGS properly. A
problem with the configure script?

Cheers,

Lionel

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://SecLists.Org


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]