Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: nmap-5.50 bug compile on OS X
From: David Fifield <david () bamsoftware com>
Date: Mon, 31 Jan 2011 02:23:38 -0800

On Sat, Jan 29, 2011 at 10:08:04AM +0100, David Munoz wrote:
Hi

On OS X 10.6.6, in using ./configure CPP=/opt/local/bin/cpp (gcc 4.5.2) or ./configure CPP=/usr/bin/cpp (Apple gcc 
4.2), during make phase, I have this error:
g++ -Lnbase -Lnsock/src/   -o nmap main.o nmap.o targets.o tcpip.o nmap_error.o utils.o idle_scan.o osscan.o 
osscan2.o output.o payload.o scan_engine.o timing.o charpool.o services.o protocols.o nmap_rpc.o portlist.o NmapOps.o 
TargetGroup.o Target.o FingerPrintResults.o service_scan.o NmapOutputTable.o MACLookup.o nmap_tty.o nmap_dns.o  
traceroute.o portreasons.o xml.o   -lnbase -lnsock -lpcre libpcap/libpcap.a -lssl -lcrypto libnetutil/libnetutil.a 
./libdnet-stripped/src/.libs/libdnet.a  -lm 
Undefined symbols:
  "get_script_scan_results_obj()", referenced from:
      nmap_main(int, char**) in nmap.o
  "script_scan(std::vector<Target*, std::allocator<Target*> >&, stype)", referenced from:
      nmap_main(int, char**) in nmap.o
      nmap_main(int, char**) in nmap.o
      nmap_main(int, char**) in nmap.o
  "ScriptResult::get_id() const", referenced from:
      formatScriptOutput(ScriptResult)       in output.o
      printhostscriptresults(Target*)     in output.o
      printscriptresults(std::list<ScriptResult, std::allocator<ScriptResult> >*, stype) in output.o
      printportoutput(Target*, PortList*)    in output.o
  "ScriptResult::get_output() const", referenced from:
      formatScriptOutput(ScriptResult)       in output.o
      printhostscriptresults(Target*)     in output.o
      printscriptresults(std::list<ScriptResult, std::allocator<ScriptResult> >*, stype) in output.o
      printportoutput(Target*, PortList*)    in output.o
  "open_nse()", referenced from:
      nmap_main(int, char**) in nmap.o
      nmap_main(int, char**) in nmap.o
  "close_nse()", referenced from:
      nmap_free_mem()     in nmap.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[1]: *** [nmap] Error 1
make: *** [all] Error 2

Please, could you describe me the right procedure to compile Nmap 5.50 on OS X?

For your information, I have no problem with Nmap 5.35DC1.

It looks like a failure to detect liblua. There should be a -llua or
liblua.a in the g++ line. Please send the contents or your config.log
file. If you want to investigate the problem yourself, search config.log
for references to "lua" and see what the build failure might be.

David Fifield
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]