Home page logo
/

nmap-dev logo Nmap Development mailing list archives

RE: Version display patch
From: "Thomas Buchanan" <TBuchanan () thecompassgrp net>
Date: Fri, 4 Feb 2011 22:39:02 -0600

-----Original Message-----
From: nmap-dev-bounces () insecure org 
[mailto:nmap-dev-bounces () insecure org] On Behalf Of ambarisha b
Sent: Friday, February 04, 2011 10:19 AM
To: nmap-dev () insecure org
Subject: Re: Version display patch

I have attached the patch for -V option.This is the output on 
my machine.
$ nmap -V

Nmap version 5.51SVN ( http://nmap.org )
Platform : i686-pc-linux-gnu
Compiled with: liblua-5.1.3 libpcre-7.6 libpcap-1.1.1 
libdnet-1.12 ipv6
Compiled without: OpenSSL

What do you think ?

Cheers
Ambarisha


Hi, 

Unfortunately, this patch breaks the nmap build on my Windows system.
Because Windows doesn't use the "configure" script, the
libdnet-stripped\include\config.h file doesn't exist, and a fatal error
is generated:

4>..\nmap.cc(124): fatal error C1083: Cannot open include file:
'libdnet-stripped\include\config.h': No such file or directory

I tried including the dnet_winconfig.h file instead, but that gave a
different error message, so I don't really have anything to suggest for
you to try differently, but did want to make you aware of the situation.

Thanks,

Thomas 
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault