Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Weird Crash - "WAITING_TO_RUNNING"
From: David Fifield <david () bamsoftware com>
Date: Sun, 9 Jan 2011 21:25:46 -0800

On Wed, Jan 05, 2011 at 04:07:41PM -0700, Nathan wrote:
I looked through the logs and identified revisions that are more likely
to have changed something in NSE betweern 5.35DC1 and 5.36TEST1. I know
this is asking a lot, but if the --datadir doesn't solve it, please try
building and testing each of these revisions:

19514 19515 20266 20267 20632 20633

Starting from a Subversion checkout, you will run

svn update --ignore-externals -r 19514 . nbase ncat nping nsock zenmap

Then build and test, using "--datadir .". Then move on to 19515, 20266,
etc. (You don't have to check out again every time.)

No, I was not using "--datadir ." before.

NOW for the long-awaited testing:

Here's the command I used to set up nmap each time (from an svn checkout):

$ svn update --ignore-externals -r $REVISION . nbase ncat nping nsock
zenmap && make clean && ./configure && make

Here's the command I'm using to test each of the versions you indicated:

$ time /usr/bin/sudo ./nmap --datadir . -sS -sV -T4 -p 1-65535
74.62.92.70 -P0 -v

...while in a separate shell I run the following command to see the
total RAM usage at the END of the run (obviously RAM usage varies
quite a bit during the run):

$ while /bin/true ; do sleep 1 && echo "---------" && date && cat
/proc/meminfo  | grep MemFree ; done

Note that nothing else is running on the box at the time except my SSH
session to it.

==> r19514: <==

Elapsed time: 14m12s
Memory usage: 4GB (crashed)

==> r19515 <==

Elapsed time: 13m31s
Memory usage: 4GB (crashed)

==> r20266 <==

Elapsed time: 14m36s
Memory usage: 4GB (crashed)

==> r20267 <==

Elapsed time: 13m58s
Memory usage: 4GB (crashed)

==> r20632 <==

Elapsed time: 14m21s
Memory usage: 4GB (crashed)

==> r20633 <==

Elapsed time: 13m5s
Memory usage: 4GB (crashed)

-------------

So what in the world did I miss?  Is this "--data_dir ." option
messing things up?  I wouldn't expect any crashes in revisions after
the nse_main.lua change...and yet they're all crashing.  The 'svn
updates' always had at least a decent number of files listed as having
been modified in the update.

This is very strange. Do you have any local changes in your working
directory? (Run "svn status" and see if there's anything other than "?"
and "X".)

I assume the same crashes don't happen without --datadir?

David Fifield
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault