Home page logo
/

nmap-dev logo Nmap Development mailing list archives

problem with nmap
From: Flavio Ferreira <xfl4v10 () googlemail com>
Date: Tue, 15 Mar 2011 02:20:34 -0300

I'm trying to run a script with nmap only am I having the following error:

root () xfl4v10:/usr/share/nmap/scripts# nmap -sV --script=mysql-brute <target>

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-15 02:09 BRT
NSE: failed to initialize the script engine:
/usr/share/nmap/nse_main.lua:223: ./mysql-brute.nse:18: module 'mysql' not
found:
    no field package.preload['mysql']
    no file './mysql.lua'
    no file '/usr/local/share/lua/5.1/mysql.lua'
    no file '/usr/local/share/lua/5.1/mysql/init.lua'
    no file '/usr/local/lib/lua/5.1/mysql.lua'
    no file '/usr/local/lib/lua/5.1/mysql/init.lua'
    no file '/usr/share/lua/5.1/mysql.lua'
    no file '/usr/share/lua/5.1/mysql/init.lua'
    no file '/usr/share/nmap/nselib/mysql.lua'
    no file './mysql.so'
    no file '/usr/local/lib/lua/5.1/mysql.so'
    no file '/usr/lib/lua/5.1/mysql.so'
    no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:
    [C]: in function 'assert'
    /usr/share/nmap/nse_main.lua:223: in function 'new'
    /usr/share/nmap/nse_main.lua:392: in function 'get_chosen_scripts'
    /usr/share/nmap/nse_main.lua:594: in main chunk
    [C]: ?

QUITTING!
root () xfl4v10:/usr/share/nmap/scripts#
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault