Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: Nmap/Ncat 5.50 Dependency Change
From: David Millis <tvtronix () yahoo com>
Date: Tue, 15 Mar 2011 18:17:03 -0700 (PDT)

A different suggestion was made at the end of last year, which sounds a > little less "hackish", but I don't think 
anyone here has tried it:
[Setting the Platform Toolset to 2008 (v90)]
That only changes which compiler is used under the hood. The nmap code genuinely requires 2010, so the old compiler 
failed for me.

The page I mentioned allows compiling apps with the 2010 compiler. I tried that today, and it worked for me.

Since this project isn't mfc-based, the more hackish steps can be skipped.
Steps I did: 5, 7-8, 9-11 (non-mfc asm reduces to the following)
----------
.model flat

.data
__imp__EncodePointer () 4 dd dummy
__imp__DecodePointer () 4 dd dummy

EXTERNDEF __imp__EncodePointer () 4 : DWORD
EXTERNDEF __imp__DecodePointer () 4 : DWORD

.code
dummy proc
mov eax, [esp+4]
ret 4
dummy endp 

end
----------
In his final note, the author mentions static linking to avoid msvcr100.dll (which itself would've wanted the needless 
funcs).
He is referring to: ncat project,Properties, C, Code Generation - Runtime Lib = Multi-Threaded (non-dll)


It amounts to setting 3 options and pasting that file.
Now I can run ncat on WinXP SP1.


David



      
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault