Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: [NSE] Check for CVE-2011-1720 - Postfix SMTP Cyrus SASL memory corruption
From: Ron <ron () skullsecurity net>
Date: Sun, 19 Jun 2011 23:49:24 -0500

On Sun, 19 Jun 2011 13:06:51 -0700 Fyodor <fyodor () insecure org> wrote:
That sounds promising.  Combining similar things into a single script
can be desirable, but I agree that smb-check-vulns maybe takes this
consolidation too far.  If split up, you might be able to keep
smb-check-vulns for the vuln-check-specific actions.  Or maybe it
would be better to just deprecate smb-check-vulns as you say and just
name all the offspring scripts separately.

In terms of deciding whether to combine scripts or not, I suppose
desirability from an end-user UI perspective should trump convenience
and ease of implementation for us as script writers.  After all, we
already have numerous techniques (libraries, etc.) for sharing code
between scripts, so we should be able to achieve both good UI and
elegant and maintainable implementations.

Cheers,
Fyodor

Another option that might be easier than any is to make smb-check-vulns.nse into kind of a "meta plugin", where it 
doesn't do anything in and of itself, but depends on all the smb vuln scripts so they automatically run when you run 
smb-check-vulns. 

Of course, the issue with that is that dependencies don't work like that right now. :)

Ron
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]