Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: psexec failing against XP and seven
From: "DePriest, Jason R." <jrdepriest () gmail com>
Date: Mon, 23 May 2011 13:47:03 -0500

Try enclosing the password in double-quotes or single-quotes.

You could also try the --script-args
'smbuser=user,smbpass="password",config=network' method instead of the
--script-args=smbuser=user,smbpass='password',config=network method.

-Jason

On Mon, May 23, 2011 at 10:10 AM, Brahim Sakka <> wrote:
Hello list,

I'm trying to use the psexec script against Windows XP :

*# nmap -n -p139,445 --script=smb-psexec
--script-args=smbuser=user,smbpass=password,config=network target_IP* *-d*


  - user/password are credentials of an admin user.


  - Attacker machine is a fully updated ubuntu 10.10.


  - I'm using Nmap v5.51.

Here is a snippet from the output:

*NSE: SMB: Added account 'user' to account list
NSE: SMB: Extended login as \user failed (NT_STATUS_LOGON_FAILURE)

PORT    STATE SERVICE      REASON
139/tcp open  netbios-ssn  syn-ack
445/tcp open  microsoft-ds syn-ack
MAC Address: 08:00:08:8C:FB:1E

Host script results:
| smb-psexec:
|_  ERROR: Couldn't find a writable share! (May not have an administrator
account)


*I got the exact same error against Windows 7.


Anyone knows how to solve this or am I missing something obvious here?
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/

_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]