Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: [NSE] Lua 5.2 Upgrade
From: David Fifield <david () bamsoftware com>
Date: Wed, 2 May 2012 00:36:23 -0700

On Mon, Apr 09, 2012 at 04:04:56PM -0700, Fyodor wrote:
On Wed, Apr 04, 2012 at 01:43:38AM -0400, Patrick Donnelly wrote:

Over the past few months I've been working on a branch that upgrades
NSE to use Lua 5.2. I'll start off by giving you the location of the
branch so you can try it out:

Thanks Patrick, this is exciting stuff!  I'm pretty sure we will want
to upgrade to Lua 5.2.  I tested your branch
(https://svn.nmap.org/nmap-exp/patrick/nse-lua52) on Linux and it
seems to be working fine.  On Windows, it compiled, but I haven't been
able to get it to work.  It gives me this message:

$ ./nmap -A -T4 scanme.nmap.org

Starting Nmap 5.61TEST5 ( http://nmap.org ) at 2012-04-09 15:56 Pacific Daylight Time
NSE: Script Engine Scan Aborted.
An error was thrown by the engine: ...ome\fyodor\nse-lua52\mswin32\nmap-5.61TEST5/nse_main.lua:902: attempt to call 
upvalue 'unpack' (a nil value)
stack traceback:
        ...ome\fyodor\nse-lua52\mswin32\nmap-5.61TEST5/nse_main.lua:902: in function 'run'
        ...ome\fyodor\nse-lua52\mswin32\nmap-5.61TEST5/nse_main.lua:1238: in function 
<...ome\fyodor\nse-lua52\mswin32\nmap-5.61TEST5/nse_main.lua:1145>
        [C]: in ?
Nmap scan report for scanme.nmap.org (74.207.244.221)
[Rest of Nmap report cut.  It was fine except that there wasn't any
 NSE results]

I haven't tried it on Mac OS X yet.  Hopefully someone will give it a
try on that platform once the Windows issue is fixed.

I tested it on OS X 10.7.3 without problems.

David Fifield
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault