Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: mysql-brute using brute library
From: Aleksandar Nikolic <nikolic.alek () gmail com>
Date: Fri, 25 May 2012 21:15:52 +0200

Heh, my bad, booted the wrong vm ...
It was a 4.1 server ...

Why is there a difference in performed guesses ?
Also, your results seem rather fast , maybe there's something going wrong?
Like server blocking you?


On Fri, May 25, 2012 at 8:54 PM, Patrik Karlsson <patrik () cqure net> wrote:


On Fri, May 25, 2012 at 8:33 PM, Aleksandar Nikolic <nikolic.alek () gmail com>
wrote:

Hi All,

I rewrote the mysql-brute script to use brute library.
I've commited it to trunk as per David's suggestion.

Here is the sample output with timing:

PORT     STATE SERVICE
3306/tcp open  mysql
| mysql-brute:
|   Accounts
|     No valid accounts found
|   Statistics
|_    Performed 2290 guesses in 600 seconds, average tps: 4

Nmap done: 1 IP address (1 host up) scanned in 602.52 seconds

And here is the output of the old script:

PORT     STATE SERVICE
3306/tcp open  mysql

Nmap done: 1 IP address (1 host up) scanned in 605.47 seconds

No noticeable increase in speed I'm afraid.
I've tested it agains my own server without default passwords on purpose.

Any suggestions?

Thanks,
Aleksandar
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


Hmm, what version are you running against? I'm running against 5.1.62 in
Ubuntu and get:

   Statistics
|_    Performed 1940 guesses in 2 seconds, average tps: 970.00


//Patrik

--
Patrik Karlsson
http://www.cqure.net
http://twitter.com/nevdull77


_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]