Home page logo
/

nmap-dev logo Nmap Development mailing list archives

Re: script-updatedb not working after LUA upgrade
From: Patrik Karlsson <patrik () cqure net>
Date: Sun, 27 May 2012 22:01:05 +0200

On Sun, May 27, 2012 at 10:25 PM, Paulino Calderon <paulino () calderonpale com
wrote:

I noticed this morning that --script-updatedb is not working after the LUA
upgrade:

NSE: Updating rule database.
Fetchfile found /usr/local/bin/../share/nmap/**scripts/
NSE: failed to initialize the script engine:
/usr/local/bin/../share/nmap/**nse_main.lua:1106: bad argument #1 to 'for
iterator' (directory expected, got userdata)
stack traceback:
   [C]: in function 'for iterator'
   /usr/local/bin/../share/nmap/**nse_main.lua:1106: in main chunk
   [C]: in ?

QUITTING!

readdir() does not return a directory anymore. Can anyone else reproduce?
______________________________**_________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/**mailman/listinfo/nmap-dev<http://cgi.insecure.org/mailman/listinfo/nmap-dev>
Archived at http://seclists.org/nmap-dev/


I can reproduce it, not sure how to fix it though.

//Patrik
-- 
Patrik Karlsson
http://www.cqure.net
http://twitter.com/nevdull77
_______________________________________________
Sent through the nmap-dev mailing list
http://cgi.insecure.org/mailman/listinfo/nmap-dev
Archived at http://seclists.org/nmap-dev/


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault